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Functions, 
Formatting Worksheets and 

Creating Charts

Excel includes hundreds of other functions that you can use to calculate results 
used in statistics, finance, engineering, Mathematics, and other fields.

Functions are structured programs that calculate a specific result: a total, an 
average, the amount of a monthly loan payment, or the geometric mean of a 
group of numbers. Each function has a specific order or syntax that must be used 
for the function to work, properly.

Functions are formulas, so all functions begin with the equal sign (=). After that 
is the function name, followed by one or more arguments separated by commas 
and enclosed in parentheses:

Example:
= SUM(D6:D11)

Functions: A better way of using Excel Power

Functions
Excel’s functions are grouped into 10 categories

Insert  Functions

1. Used to ensure a formula is entered with the correct syntax.

2. Allows browse to values as the formula is written.

Financial Functions
NPV Function

Calculates the net 
present value of an 
investment by using 
a discount rate and 
a series of future 
payments (negative 
values) and income 
(positive values).
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Financial Functions
NPV Function

Calculates the net 
present value of an 
investment by using 
a discount rate and 
a series of future 
payments (negative 
values) and income 
(positive values).

Financial Functions
PMT Function

Calculates the 
payment for a loan 
based on constant 
payments and a 
constant interest 
rate.

Financial Functions
RATE Function

Returns the interest 
rate per period of an 
annuity. RATE is 
calculated by 
iteration and can 
have zero or more 
solutions. 

Financial Functions
FV Function

Returns the future 
value of an 
investment based 
on periodic, 
constant payments 
and a constant 
interest rate.

Financial Functions
PV Function

Returns the present 
value of an 
investment. The 
present value is the 
total amount that a 
series of future 
payments is worth 
now. 

FREEZE PANES

If you have a large 
worksheet with 
column and row 
headings, those 
headings will 
disappear as the 
worksheet is scrolled. 

By using the Freeze 
Panes feature, the 
headings can be 
visible during editing. 

Restructuring Worksheet
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You can split any 
sheet in a workbook 
horizontally, vertically, 
or both vertically and 
horizontally. 

Splitting sheets into 
panes offers 
synchronized scrolling 
capability.

Splitting Panes

•Splitting a window allows you to work on multiple 
parts of a large spreadsheet simultaneously

•Freezing the pane allows you to always keep one 
part of the spreadsheet (e.g., column or row labels) 
visible

Splitting Panes

1. Drag the split 
horizontal and split 
vertical icons to the 
desires positions

2. Click on the freeze 
pane icon from the 
tool bar to freeze 
the panes

Exercise

1. Split the screen so that:
• The row with column labels shows up in the top 

pane 
• The column with store names show up in the left 

pane
2. Freeze the panes

Split screen icons

Remember that before 
you do any formatting, you 
must SELECT (highlight) 
the items to be formatted.

•To select individual cells, 
just click on them

•To select adjacent cells. 
Click and drag to include 
them

•To select several cells 
which are not adjacent, 
hold down the Ctrl key and 
click on each cell to 
include.

Formatting Worksheet

•Select a 
column

•Select a 
row

•To select the entire 
worksheet click upper 
left corner

Formatting Dialog box

This dialog box is very 
similar to what you 
learned about in MS 
Word. You should be 
able to experiment with 
the tools found on each 
of the tabs.

Formatting Dialog box

• Number tab – enables you to specify the type of value contained 
in a cell and how it should be displayed.

• Alignment tab - you may align text within the cells either 
horizontally or vertically and then choose left, center, right, justify or 
centered.

• Fonts tab – you may format the size, colour, style, and font family 
to be used.

• Border tab - enables you to create a border around a cell or range. 

• Fill tab - lets you choose a different color to shade the cell or range

Formatting Dialog box

• General - the default format for numeric entries and 
displays the way it was entered.

• Number - displays a number without the thousands 
separator comma and with any number of decimal places.

• Currency - displays a number with the 1000 separator 
comma and an optional dollar sign and negative values (in 
red or minus sign).

• Accounting - displays a number with the thousand 
separation, optional dollar sign (leftmost aligned) negative 
values in ( ) and zero values as hyphens.

• Date - displays a date in various date formats. 
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Formatting Dialog box

• Time - displays the time in various time formats.

• Percentage - the number is multiplied by 100 before is 
displayed with a % sign.

• Fraction - displays a number as a fraction such as ¼.

• Scientific - displays a number as a decimal followed by the 
exponent of base 10.

• Text - left aligns the entry; useful for numbers that are not 
used in calculations such as zip codes.

• Special - displays a number with extra characters such as ( ) 
around a phone number area code.

• Custom - allows you to develop your own formats.

Format Cell

The Format Cells 
dialog box has 
separate pages for 
Number, 
Alignment, Font, 
Border, Patterns, 
and Protection. 

Formatting Fonts

You can also change the 
look of a font by changing 
its color, style, and size. 

You can apply these font 
formatting options to the 
entire contents of a cell or 
range, or you can apply 
them to selected 
characters within a cell.

The complete font 
formatting options are 
available on the Font tab 
of the Format Cells dialog 
box.

Fonts

You can change:
Font
Font style
Size
Color
Underline
Effects

Formatting Numbers Change Number Format

One of the tabs in 
the format dialog 
box is new.  It is 
the FORMAT 
NUMBER tab. 

Remember to select 
the cells, columns, 
rows or entire 
spreadsheet before 
you choose the 
format for you 
numbers or dates.
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Widening  Column

If the entered text 
exceeds the column 
width it will overlap 
the boundary into the 
next column when 
that column is blank. 
If the next column 
already contains 
data, text that does 
not fit in the cell is 
hidden.

To increase column width, drag the right side 
of the column header with the double-
headed pointer. 

To make the column width fit the contents of 
its widest cell, double-click the boundary on 
the right side of the column 

Changing Row Height

Select a row and move your cursor to the 
row’s border to use the row height 

handler.

Insert Column or Row

To insert a single column, click any cell in the column immediately to 
the right of where you want the new column to go. Then, on the Home
tab, in the Cells group, click the arrow on Insert. On the drop-down 
menu, click Insert Sheet Columns. A new blank column is inserted.

To insert a single row, click any cell in the row immediately below
where you want the new row to go. For example, to insert a new row 
between row 4 and row 5, click a cell in row 5. Then in the Cells group, 
click the arrow on Insert. On the drop-down menu, click Insert Sheet 
Rows. A new blank row is inserted.

Insert a New Row

1. Select a row 
by clicking on 
the number 
heading.

2. Right click 
your mouse 
and choose 
Insert.

Adding a New Column
1. Select a column 
by clicking on the 
letter heading.

2. Right click your 
mouse and choose 
Insert.

Deleting a Row or Column
1. Select the row or 
column that you 
want to delete by 
clicking on the 
heading.

2. Right click your 
mouse and choose 
Delete.
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Alignments Borders

To distinguish 
between different 
types of information 
in a worksheet, you 
can apply borders to 
cells, shade cells with 
a background color, 
or shade cells with a 
color pattern.

Borders Fills and Patterns

Fill Colors

Select the cells that user 
want to apply shading to or 
remove shading from. 

On the Home tab, in the 
Font group, do one of the 
following: 

To fill cells with a solid 
color, click the arrow next 
to Fill Color in the Font 
group on the Home tab, 
and then click the color on 
the palette that user want. To apply the most recently selected color, click 

Fill Color . 

Format Style

On the worksheet, select a 
range of cells that user 
want to quickly format as 
a table. 

On the Home tab, in the 
Styles group, click Format 
as Table. 
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Table Style

•On the worksheet, select 
the table to which user 
want to apply a table style. 

•On the Design tab, in the 
Table Styles group, do one 
of the following: 

1.Click the table style 
that user want to use. 
2.Click the More
button 

Conditional Style

Use a conditional 
format to help you 
visually explore and 
analyze data, detect 
critical issues, and 
identify patterns and 
trends.

Conditional Formatting

• Conditional formatting 
of cells allows for 
better representation 
of data.

Copy and Paste

When you move or 
copy rows and 
columns, Microsoft 
Office Excel moves or 
copies all of the data 
that they contain, 
including formulas 
and their resulting 
values, comments, 
cell formats, and 
hidden cells

Find and Replace

Enter the 
information that you 
want to search for. 
You can use a 
question mark (?) to 
match any single 
character or an 
asterisk (*) to match 
any string of 
characters. 

Chart

 Charts are graphical 
representation of 
numeric data.

 Excel supports 
numerous chart types.

 Use different chart 
types to portray 
different kinds of 
information.
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Create a basic Chart
1. Select the data that you 
want to chart, including 
the column titles (January, 
February, March) and the 
row labels (the 
salesperson names).

2.Then click the Insert tab, 
and in the Charts group, 
click the Column button. 
You could select another 
chart type, but column 
charts are commonly used 
to compare items and will 
get your point across.

Create a basic Chart
3. After you click Column, 
you'll see a number of 
column chart types to 
choose from. Click 
Clustered Column, the 
first column chart in the 2-
D Column list. 

Chart Types: Column Chart
Data that is arranged in 
columns or rows on a 
worksheet can be plotted 
in a column chart. 

Column charts are useful 
for showing data changes 
over a period of time or 
for illustrating 
comparisons among 
items. 

In column charts, 
categories are typically 
organized along the 
horizontal axis and values 
along the vertical axis.

Chart Types: Line Chart
Data that is arranged in 
columns or rows on a 
worksheet can be plotted 
in a line chart. 

Line charts can display 
continuous data over 
time, set against a 
common scale, and are 
therefore ideal for 
showing trends in data at 
equal intervals. 

In a line chart, category 
data is distributed evenly 
along the horizontal axis, 
and all value data is 
distributed evenly along 
the vertical axis. 

Chart Types: Pie Chart
Data that is arranged in 
one column or row only 
on a worksheet can be 
plotted in a pie chart. 

Pie charts show the size of 
items in one data series

Pie chart are displayed as 
a percentage of the whole 
pie. 

Chart Types: Bar Chart
Data that is arranged in 
columns or rows on a 
worksheet can be plotted 
in a bar chart. 
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Chart Types: Doughnut Chart
Data that is arranged 
in columns or rows 
only on a worksheet 
can be plotted in a 
doughnut chart. Like a 
pie chart, a doughnut 
chart shows the 
relationship of parts 
to a whole, but it can 
contain more than 
one data series

Chart Items

Legend

y-axis or 
Value Axis

Major Gridline

Data Label

Data Marker

x-axis or 
Category Axis

Axis Title

Chart Title

Axis Title

Chart Area

Plot Area Minor Gridline

Category

Scale Value

Query Session

Keep Practicing Excel


